Users unable to submit session notes via the website

Incident Report for Rethink BH status page

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 17:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2025 - 14:18 EDT

Investigating

We have received reports of some users being unable to submit session notes via the website. Our Development Team is investigating this issue and is working on resolving it as quickly as possible.
Posted Aug 27, 2025 - 10:06 EDT