Data Entry Degredation

Incident Report for RethinkBH

Resolved

This issue has been resolved, a fix has been implemented and monitored and we are seeing restored access
Posted Aug 19, 2026 - 13:20 EDT

Investigating

We are currently investigating reports of users encountering error messages while entering clinical data on the web browser’s “Data Entry” page.
Posted Aug 19, 2026 - 12:34 EDT