Data Entry Messaging

Incident Report for RethinkBH

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 09:46 EDT

Monitoring

A fix has been implemented and we are monitoring the fix.
Posted Jun 24, 2026 - 19:15 EDT

Investigating

We are receiving reports of users receiving error messaging when entering in data via the apps and some reports of web browser. Our team is actively investigating this
Posted Jun 24, 2026 - 16:48 EDT