Site Slowness

Incident Report for RethinkBH

Monitoring

A fix for this issue has been implemented. We are continuing to monitor site performance.
Posted Mar 30, 2026 - 15:01 EDT

Investigating

We have received reports of site slowness from several users. We are investigating these reports and are working on a resolution as quickly as possible.
Posted Mar 30, 2026 - 12:06 EDT