Site Slowness

Incident Report for RethinkBH

Resolved

This incident has been resolved.
Posted Dec 24, 2025 - 10:36 EST

Update

We are still seeing intermittent performance issues. We are continuing to work on resolving these issues as quickly as possible.
Posted Dec 15, 2025 - 12:19 EST

Update

We are continuing to monitor for any further issues.
Posted Dec 15, 2025 - 12:18 EST

Monitoring

The reset has been completed and we are continuing to monitor site performance.
Posted Dec 15, 2025 - 11:11 EST

Identified

The issue has been identified, and we will need to reset the application to implement the correction.

We are planning to initiate the reset at 11:00 AM EST (in 10 minutes).
During this time, users may receive errors and experience slowness for several seconds.
As the services restart, we should see a return to normal within 10-15 minutes.

We will continue to update our status page as we work through these items.
Posted Dec 15, 2025 - 10:50 EST

Investigating

We have received reports from several users of slower than normal performance on the Rethink Behavioral Health Platform. We are investigating this issue and are working on a resolution. We will continue to update this post as we work towards this resolution.
Posted Dec 15, 2025 - 09:58 EST