Performance Issues

Incident Report for RethinkBH

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 11:58 EDT

Monitoring

A fix has been implemented for this issues. We are continuing to monitor the performance of the RethinkBH platform. If you continue to experience performance issues, please try utilizing an incognito browser window. This can be opened on any browser by clicking CTL (Command on a Mac)+Shift+N when you have a browser open.
Posted Mar 02, 2026 - 12:01 EST

Investigating

We have received reports of slow loading across the site. We are investigating these issues and working on a resolution as quickly as possible. We will continue to provide updates as the situation evolves.
Posted Mar 02, 2026 - 11:01 EST