Fire Tablet - BH+ Login

Incident Report for RethinkBH

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 11:56 EDT

Investigating

We have received reports of users utilizing Amazon Fire Tablets experiencing issues logging in to the BH+ app and receiving an 'offline' connection messaging. Our team is investigating the issue and working to identify a resolution. We’ll provide updates as more information becomes available.
Posted Aug 28, 2026 - 16:43 EDT