The update is live in the app store for legacy app on iOS. Please download version 26.2.1.
IMPORTANT: If you were experiencing syncing issues, please do not delete the app, please download directly from the app store without deletion. For legacy app, information is saved directly onto the device until it is synced to the server. If the app is deleted, this will remove any stored information.
Posted Jun 07, 2026 - 21:17 EDT
Monitoring
A fix has been sent to the app store and is awaiting publishing from Apple. This issue was only reported and observed by iOS Legacy app users. New version number will be 26.2.1.
Posted Jun 05, 2026 - 17:40 EDT
Identified
We have received reports that the legacy app is requiring staff to input data which meets the required minimum trials prior to syncing / saving the information. We are investigating this issue, have identified the source and working on a resolution.