Performance Issue - Group Calendar

Incident Report for RethinkBH

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 12:06 EDT

Investigating

We have received reports of slow loading times within the Group Calendar as well as other areas of the Scheduler. We are investigating this issue and are working on resolving it as quickly as possible.
Posted Mar 26, 2026 - 12:29 EDT