Users unable to open or verify Travel Appointments
Incident Report for Rethink BH status page
Resolved
This issue is now resolved. Please contacting Rethink Support at https://www.rethinkbehavioralhealth.com/support/ if you continue to run into issues opening Travel Appointments.
Posted Nov 11, 2024 - 18:01 EST
Monitoring
A fix has been released to address the issue of users being unable to open Travel Appointments on the scheduler. We will continue to monitor this issue to ensure that the fix is working as intended.
Posted Nov 11, 2024 - 15:34 EST
Investigating
We have received reports from several users that they are unable to open or verify travel appointments. Our Development Team is investigating this issue. We will provide updates as soon as they are available.
Posted Nov 11, 2024 - 09:19 EST