Site Loading / Performance

Incident Report for RethinkBH

Resolved

This incident has been resolved
Posted Sep 03, 2026 - 13:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2026 - 09:37 EDT

Investigating

We are currently investigating reports of the site loading slowly or not responding for some customers. Our team is actively working to identify the cause and restore normal performance.

We apologize for the disruption and appreciate your patience while we work to resolve this issue.
Posted Aug 31, 2026 - 09:02 EDT