Mobile App loading issues and Website slowness

Incident Report for Rethink BH status page

Resolved

This issue has now been resolved.

If you continue to experience these issues, please try fully closing and reopening the RethinkBH mobile app or clearing the cache and cookies on your browser before reaching out to RethinkBH support at https://www.rethinkbehavioralhealth.com/support/
Posted Apr 04, 2025 - 14:51 EDT

Monitoring

A fix has been launched for this issue. We are continuing to monitor the mobile app and website performance closely.

If you continue to experience these issues, please try fully closing and reopening the RethinkBH mobile app or clearing the cache and cookies on your browser before reaching out to RethinkBH support at https://www.rethinkbehavioralhealth.com/support/
Posted Apr 04, 2025 - 09:56 EDT

Investigating

We are receiving reports of loading issues on the RethinkBH mobile app as well as slowness on the website. We are investigating these issues with the highest priority and are working on resolving them as quickly as possible. We will post updates regarding this issue as soon as we have them.
Posted Apr 04, 2025 - 09:12 EDT